mercredi 4 février 2009

Using the webcam with kernel 2.6.27

After updating you kernel to version 2.6.27, some applications like skype and cheese may crash or not be able to play webcam videos. This is due to the incompatibility between V4L1 and V4L2.

Note that drivers gspca has been integrated in the kernel starting from 2.6.27 and use V4L2 instead of V4L1.

The solution for this problem consists on downloading the compatibily labraries and then to load them before starting the application.

On Fedora, this can be done with the following commands (as root):

For i386

wget \

rpm -ivh libv4l-0.5.4-1.fc9.i386.rpm

LD_PRELOAD=/usr/lib/libv4l/ cheese

For x86_64

wget \

rpm -ivh libv4l-0.5.4-1.fc9.x86_64.rpm

LD_PRELOAD=/usr/lib64/libv4l/ cheese

2 commentaires: